Running the mod is a pain in the butt

If you are experiencing problems with the mod here is the place to ask for help. Bug reports are also welcome here.
Post Reply
Pengbumstot
Posts: 3
Joined: Mon Jan 25, 2016 2:48 pm

Running the mod is a pain in the butt

Post by Pengbumstot » Mon Jan 25, 2016 3:19 pm

Hi guys,

Just came across the mod on moddb. Played this a long time ago and really appreciate that you're still keeping it alive. But I have to say installing it is kind of pain in the ass without any step by step readme. Maybe I'm just too stupid, but as I understood it from reading some comments on moddb as well as the 2 already existing threads about the missing exe:

1. Download the Source SDK Base version 2007 over the tools section in steam and run it once.
2. Download and install the client (making sure it copies everything to the right path).
3. Download and apply the patch (manually copy&paste).
4. Restart steam to make the Mod appear in the game library.

My problem: there is no executable to run the game, only the uninstall.exe. Further steam does not recognize it and therefore doesn't list in in my game library. I already tried the suggested fixes (reinstalling/downloading of both the SDK and the mod) with no effect.

I hope that you can help me and that you will add a better readme (including the most common problems) to the download. I'm sure getting rid of some obstacles in the installation would help making the mod more attractive and fill the servers again. There's really no alternative involving blackpowder weapons in a multiplayer environment aside from the Mount & Blade Series.

Greetings from Germany :mrgreen:

Nathan Hale
Posts: 189
Joined: Fri Apr 04, 2014 2:50 am

Re: Running the mod is a pain in the butt

Post by Nathan Hale » Mon Jan 25, 2016 8:21 pm

We have someone working on a full installer, to replace the current system for installing the game. You are not the first person to complain. This method of installation was the norm for many years, but is out-of-date now. Did you check to make sure the mod files went into the correct folder?
Battle Grounds: Since 2001
Image

Pengbumstot
Posts: 3
Joined: Mon Jan 25, 2016 2:48 pm

Re: Running the mod is a pain in the butt

Post by Pengbumstot » Tue Jan 26, 2016 12:45 pm

I had to adjust the path since I placed steam on my SSD and the games on a normal Harddrive.
But it ends on "SteamApps\SourceMods\bg2" so it should be fine.

I don't think it's out of date. I'm totally fine with extract-to-installers as well as manual patching, as long as it works and extracts all the files properly ^^

Is it possible that I got a corrupt installer? So downloading it from a different mirror would help?

klifsnider
Posts: 87
Joined: Sat Mar 01, 2014 11:02 am

Re: Running the mod is a pain in the butt

Post by klifsnider » Tue Jan 26, 2016 1:53 pm

Pengbumstot wrote:I had to adjust the path since I placed steam on my SSD and the games on a normal Harddrive.
But it ends on "SteamApps\SourceMods\bg2" so it should be fine.
Unfortunately it's not possible to do this. Steam only looks in it's original installation directory for mods (your SSD). It's not something we have control over.
There is a way around this if you google it, you can link the folders together I think. Or simply move bg2 to the SSD.

Pengbumstot
Posts: 3
Joined: Mon Jan 25, 2016 2:48 pm

Re: Running the mod is a pain in the butt

Post by Pengbumstot » Tue Jan 26, 2016 4:23 pm

Thanks! That was the problem.
I put everyhting into the the original steam folder and it works like a charm. It's listed in the library, runs, the servers are visible, etc.

As it is just this mod, I have no intention to link it to my external steamapps-folder, but thx for mentioning it. I think this stackexchange article is a good starting point for whoever is interested in that solution:
http://gaming.stackexchange.com/questio ... -partition

Thx for responding so quickly to my question :)

Post Reply